To view uptime history for your instance of Canvas, click here.

CanvaDocs is not returning previews for users in Singapore
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 02:58 MDT
Investigating
We are currently investigating this issue.
Posted Jun 05, 2024 - 20:04 MDT
This incident affected: Canvas (Canvas LMS).