To view uptime history for your instance of Canvas, click here.

Students are seeing errors when accessing connected Grade Exchange assignments.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 13, 2024 - 09:22 MDT
Investigating
We are currently investigating this issue.
Posted May 13, 2024 - 08:19 MDT
This incident affected: Canvas (Student ePortfolios).