To view uptime history for your instance of Canvas, click here.

Some schools in the AWS US east region might experience some slowness when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 10:06 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2021 - 09:56 MDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2021 - 09:50 MDT
This incident affected: Canvas (Canvas LMS).