To view uptime history for your instance of Canvas, click here.

Slow load times when accessing Canvas

Incident Report for Instructure

Resolved

Load times have returned to normal and have held steady without further errors. Thank you for your patience while our team implemented the fix.
Posted Apr 20, 2020 - 09:59 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2020 - 08:58 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 20, 2020 - 08:43 MDT

Investigating

We are currently investigating an issue where some users are running into longer than normal load times when accessing Canvas
Posted Apr 20, 2020 - 08:31 MDT
This incident affected: Canvas (Canvas LMS).