To view uptime history for your instance of Canvas, click here.

Some users are unable to load Admin Analytics and some components of Intelligent Insights

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 04:19 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2025 - 02:21 MDT
This incident affected: Canvas (Canvas LMS), Instructure, and AWS Region (us-east-1, us-west-2).