To view uptime history for your instance of Canvas, click here.

Some users attempting to access Canvas may be getting page errors or slow load times.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 24, 2023 - 15:01 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2023 - 14:54 MDT
Investigating
We are currently investigating this issue.
Posted May 24, 2023 - 14:29 MDT
This incident affected: Canvas (Canvas LMS).