Imports and exports are running slowly or failing for some Canvas users
Incident Report for Canvas
Resolved
Imports and exports are now running as they should. We sincerely apologize for the hassle that delays and failures caused for you this morning. We'll monitor the jobs queues closely throughout the day to make sure things stay healthy.
Posted 5 months ago. Jun 29, 2018 - 10:56 MDT
Monitoring
We've deployed the fix to production, and we see wait-times on imports and exports dropping quickly. We'll provide one more update in about 15 minutes. Thank you for your patience!
Posted 5 months ago. Jun 29, 2018 - 10:47 MDT
Update
Engineers have validated the fix on staging. We'll deploy it to production as soon as possible and provide an update in 15 minutes or when it's deployed, whichever is sooner.
Posted 5 months ago. Jun 29, 2018 - 10:20 MDT
Update
Our engineers are testing the fix they've prepared in a staging environment for the issue that is causing some imports and exports to run slowly or fail this morning. We hope to have it ready and out the door soon. We'll provide another update in 15 minutes. We apologize for the trouble this is causing for you and your users.
Posted 5 months ago. Jun 29, 2018 - 09:57 MDT
Identified
Our engineers have identified the likely cause of the trouble. They're preparing a change that should improve performance shortly. We'll provide another update in 15 minutes.
Posted 5 months ago. Jun 29, 2018 - 09:32 MDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Jun 29, 2018 - 09:02 MDT
Investigating
Imports and exports are running slowly or failing for some users. This includes course imports / exports and jobs like manual SIS imports and running reports. Our engineers are investigating. Sorry for the trouble! We'll provide an update in 15 minutes.
Posted 5 months ago. Jun 29, 2018 - 08:43 MDT
This incident affected: — Imports and exports.