To view uptime history for your instance of Canvas, click here.

Some Canvas users are experiencing slow load times and even page errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 12, 2020 - 18:16 MDT
Monitoring
A small portion of Canvas users may be experiencing slowness or even page errors. Our DevOps team is aware of the issue and are already addressing the cause of the errors. We appreciate your patience with this situation.
Posted Apr 12, 2020 - 18:12 MDT