To view uptime history for your instance of Canvas, click here.

A small amount of Canvas users are experiencing long load times or error messages when attempting to load Canvas, this would potentially affect North American users.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 11, 2021 - 12:46 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2021 - 12:34 MDT
Investigating
We are currently investigating this issue.
Posted Oct 11, 2021 - 12:33 MDT
This incident affected: Canvas (Canvas LMS).