To see historical uptime for Canvas and other services for a specific instance, click here.

Slow load times in Canvas
Incident Report for Instructure
Resolved
Canvas is back to normal functionality. We apologize for any inconvenience this incident has caused.
Posted Mar 18, 2020 - 10:46 MDT
Monitoring
Load times appear to have gone back to normal. We will continue to monitor this and will update when we are in the all-clear. We appreciate your patience.
Posted Mar 18, 2020 - 10:36 MDT
Investigating
Some users may be having trouble loading Canvas at this time. We are looking into this issue and will provide updates as they come.
Posted Mar 18, 2020 - 10:23 MDT
This incident affected: Canvas (Canvas).