To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times or page errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 14, 2021 - 12:58 MST
Monitoring
Our developer team has taken action to restore load times to normal. We will continue to monitor the results.
Posted Feb 14, 2021 - 12:01 MST
Identified
Our Developer team has identified what is causing the long load times and are actively correcting this.
Posted Feb 14, 2021 - 11:49 MST
Investigating
Our team is actively investigating the cause of these page errors.
Posted Feb 14, 2021 - 11:43 MST
This incident affected: Canvas (Canvas LMS).