To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 11, 2020 - 10:53 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2020 - 10:45 MDT
Investigating
We are currently investigating this issue.
Posted Oct 11, 2020 - 10:06 MDT
This incident affected: Canvas (Canvas, — Catalog, — Chat, — Collaboration, — Commons, — Conferences, — Document previewing, — Imports and exports, — Media tools, — Notifications, — Support: Phones/Chat, — Support: Webform/email, — ePortfolios, — Gauge).