To view uptime history for your instance of Canvas, click here.

Big Blue Button is experiencing some issues currently.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 20:43 MDT
Investigating
We are currently investigating this issue.
Posted Mar 12, 2020 - 20:35 MDT