To view uptime history for your instance of Canvas, click here.

A small amount of users maybe experiencing long load times or when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 09:21 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2021 - 09:09 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 14, 2021 - 09:06 MST
This incident affected: Canvas (Canvas).