To view uptime history for your instance of Canvas, click here.

Some users may be experiencing slow page load times in Commons.
Incident Report for Instructure
Resolved
Our DevOps team has identified the issue and Canvas Commons has resumed normal service. Thank you for your patience and we apologize for any inconvenience.
Posted Mar 27, 2018 - 02:04 MDT
Investigating
Some users may be experiencing slow page load times when using Canvas Commons. Our DevOps team is investigating. We apologize for any inconvenience caused.
Posted Mar 27, 2018 - 01:47 MDT