To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 09:30 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2020 - 09:11 MDT
Investigating
We are currently investigating this issue.
Posted Sep 25, 2020 - 09:04 MDT
This incident affected: Canvas (Canvas).