To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 07:54 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2020 - 07:47 MDT
Investigating
Some users are experiencing slow loading times when attempting to login to Canvas. We are currently investigating the issue.
Posted Jul 09, 2020 - 07:14 MDT
This incident affected: Canvas (Canvas LMS).