Canvas Support Phones System
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 30, 2020 - 06:20 MDT
Investigating
The phone provider for Canvas Support is currently experiencing technical problems. Due to this fact reaching Canvas Support via phone may take longer than normal. You are still able to contact Canvas Support via our chat tool, email, and the help menu.
Posted May 30, 2020 - 06:18 MDT
This incident affected: Canvas (— Support: Phones/Chat).