To view uptime history for your instance of Canvas, click here.

Some users in US are seeing slow load times in Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 25, 2019 - 09:17 MST
Monitoring
Our Devops team was able to deploy a fix and users should be seeing normal load times when accessing Canvas
Posted Feb 25, 2019 - 08:47 MST
Investigating
We are aware of an issue where users are seeing slower than normal load times in Canvas. Our Devops team is currently looking into what is causing this issue.
Posted Feb 25, 2019 - 08:14 MST
This incident affected: Canvas (Canvas LMS).