To view uptime history for your instance of Canvas, click here.

A subset of users are experiencing longer than normal load times and page timeouts when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 15:43 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2021 - 15:31 MST
Investigating
A subset of users are experiencing longer than normal load times and page timeouts when accessing Canvas. Our Devops team is investigating the issue, we'll provide an update shortly.
Posted Feb 12, 2021 - 15:27 MST
This incident affected: Canvas (Canvas).