To view uptime history for your instance of Canvas, click here.

Region-specific Increased Latency in Canvas Catalog

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted May 09, 2024 - 15:17 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 09, 2024 - 15:11 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 09, 2024 - 15:03 MDT

Investigating

Some users in the North American region may encounter latency when accessing Canvas Catalog.
Posted May 09, 2024 - 15:01 MDT
This incident affected: Canvas (Canvas Catalog) and AWS Region (us-east-1).