To view uptime history for your instance of Canvas, click here.

Some users are encountering long load times or 503 errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 12, 2022 - 16:12 MST
Monitoring
We have found the cause and have applied a fix for this behavior. We are now monitoring results.
Posted Dec 12, 2022 - 15:37 MST
Investigating
Some users in the are encountering long load times or page errors when attempting to access Canvas. We are currently looking into this behavior.
Posted Dec 12, 2022 - 15:31 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (ap-southeast-2).