To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times or error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 07:45 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 07:39 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2020 - 07:36 MDT
This incident affected: Canvas (Canvas).