To view uptime history for your instance of Canvas, click here.

Some Users May Encounter Long Load Times While Accessing Canvas

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Jan 16, 2023 - 19:37 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2023 - 19:24 MST

Identified

Our engineering team has alerted us to possible long load times for users. They have identified the cause and are currently working on a resolution.
Posted Jan 16, 2023 - 19:18 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).