To view uptime history for your instance of Canvas, click here.

Some Canvas users experiencing slow load times
Incident Report for Instructure
Resolved
Our DevOps Team has resolved the slow page load times for the users effected. Service has been restored. Thank you all for your patience.
Posted Oct 17, 2018 - 05:53 MDT
Identified
Our DevOps team was able to identify the cause of the slow load times in Canvas. Service has been restored and we will continue to monitor the load times. Thank you all for your patience.
Posted Oct 17, 2018 - 05:35 MDT
Investigating
Some Canvas users may be experiencing slow page load times. Our DevOps team is aware and is investigating. We apologize for any inconveniences this may be causing
Posted Oct 17, 2018 - 05:32 MDT