Some users may be experiencing some page errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 18:27 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2020 - 18:17 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2020 - 18:16 MDT
Investigating
We are currently investigating this issue.
Posted Jun 01, 2020 - 18:14 MDT
This incident affected: Canvas (Canvas).