To view uptime history for your instance of Canvas, click here.

Canvas Credentials support email service is experiencing a delay
Incident Report for Instructure
Resolved
The issue has been resolved.
Posted Jul 21, 2023 - 12:16 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 21, 2023 - 08:35 MDT
Identified
The support team may not be receiving some emails sent to customer support. Our System Admins are looking into the issue and we suspect they will be retrieved, however there will be a delay not typical to our normal support responses because of this.
Posted Jul 21, 2023 - 08:34 MDT
This incident affected: Canvas (Canvas Credentials).