To view uptime history for your instance of Canvas, click here.

Long Long Times and Page Errors when Accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 31, 2020 - 19:12 MDT
Monitoring
At this time all load times and 504 errors should be resolved. We will continue to monitor this.
Posted May 31, 2020 - 18:46 MDT
Update
We are continuing to investigate this issue.
Posted May 31, 2020 - 18:30 MDT
Investigating
Some users are experiencing long load times and 504 errors when accessing Canvas. Our team is currently investigating this issue.
Posted May 31, 2020 - 18:12 MDT
This incident affected: Canvas (Canvas LMS).