To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
Canvas has resumed normal operations, and users are no longer experiencing long load times. We thank you for your patience.
Posted Dec 12, 2019 - 11:43 MST
Monitoring
Our DevOps team have implemented a fix, and it looks like users are experiencing normal load times. We'll monitor the situation closely for the next few minutes.
Posted Dec 12, 2019 - 11:27 MST
Update
Our team is continually working to implement a solution to the load times. We'll provide another update on this in a few minutes.
Posted Dec 12, 2019 - 11:19 MST
Identified
Our team has identified the cause, and are working to implement a solution. We'll provide another update in on this in a few minutes.
Posted Dec 12, 2019 - 11:04 MST
Investigating
Some users are experiencing long load times when accessing Canvas. Our DevOps team are currently investigating this issue, and we'll provide an update in a few minutes.
Posted Dec 12, 2019 - 10:49 MST
This incident affected: Canvas (Canvas).