To view uptime history for your instance of Canvas, click here.

Long Load Times when Accessing New Quizzes
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 07, 2022 - 17:24 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 07, 2022 - 16:38 MST
Identified
Our Engineering team is actively investigating and working to correct the New Quizzes load times. At this time users are still experiencing this behavior. Our engineers have located the cause and are currently working on implementing a resolution.
Posted Dec 07, 2022 - 16:26 MST
Investigating
Users are experiencing long load times when accessing New Quizzes in Canvas. We will update this status as we have additional information.
Posted Dec 07, 2022 - 16:07 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (ap-southeast-2).