To view uptime history for your instance of Canvas, click here.

Admin and New Analytics Failing to Respond Intermittently
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 16, 2024 - 15:20 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2024 - 15:05 MDT
Investigating
Some users may encounter long load times or "failed to respond" errors when accessing New Analytics or Admin Analytics.
Posted May 16, 2024 - 14:48 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).