To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 09:05 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2020 - 08:50 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 07, 2020 - 08:42 MDT
Update
We are continuing to investigate this issue.
Posted Aug 07, 2020 - 08:27 MDT
Investigating
A small subset of users are experiencing long load times when accessing Canvas. Our DevOps team is currently investigating this issue, and we'll provide an update shortly.
Posted Aug 07, 2020 - 08:11 MDT
This incident affected: Canvas (Canvas).