To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing longer than normal load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 09:57 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2021 - 09:48 MST
This incident affected: Canvas (Canvas LMS).