To view uptime history for your instance of Canvas, click here.

Canvas Page Errors - IAD Region as well as some users on the PDX Region
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 10:13 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 28, 2022 - 09:35 MDT
Identified
We believe we may have identified the issue and are working on another fix that may resolve this.
Posted Apr 28, 2022 - 09:17 MDT
Update
We are continuing to investigate this issue.
Posted Apr 28, 2022 - 09:08 MDT
Investigating
A fix has gone out to help get files to load slowly, we are still investigating this situation
Posted Apr 28, 2022 - 08:39 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 28, 2022 - 07:39 MDT
Update
We are continuing to investigate this issue.
Posted Apr 28, 2022 - 07:20 MDT
Update
We are continuing to investigate this issue.
Posted Apr 28, 2022 - 07:07 MDT
Investigating
We are currently investigating users experiencing - Service is currently unavailable. Try again later - Errors in Speedgrader, as well as links to Files.
Posted Apr 28, 2022 - 06:43 MDT
This incident affected: Canvas (Canvas LMS).