To view uptime history for your instance of Canvas, click here.

Some users experiencing errors and degraded performance in Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 17:28 MDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 22, 2023 - 17:13 MDT
Identified
The issue has been identified and a fix is being pushed
Posted Sep 22, 2023 - 17:12 MDT
Update
Our engineers are still investigating the cause of the page load errors
Posted Sep 22, 2023 - 16:55 MDT
Update
Our engineers are investigating the cause of the page load errors
Posted Sep 22, 2023 - 16:30 MDT
Investigating
We are currently investigating this issue.
Posted Sep 22, 2023 - 16:30 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (ca-central-1).