To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 19, 2020 - 11:53 MDT
Investigating
We are currently investigating this issue.
Posted Apr 19, 2020 - 11:45 MDT