To view uptime history for your instance of Canvas, click here.

Some users are experiencing page errors with Studio.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 14:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 14:12 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 29, 2021 - 14:09 MDT
Update
We are continuing to investigate this issue.
Posted Apr 29, 2021 - 13:55 MDT
Investigating
We are currently investigating this issue.
Posted Apr 29, 2021 - 13:36 MDT
This incident affected: Canvas (— Media tools).