To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
Load times have returned to normal.
Posted Oct 05, 2020 - 11:53 MDT
Monitoring
Load times have scaled down and returned to normal. We will continue to watch the situation to ensure that they remain at acceptable levels.
Posted Oct 05, 2020 - 11:45 MDT
Investigating
Our team is currently investigating why some users are receiving page errors or long load times when accessing Canvas.
Posted Oct 05, 2020 - 11:38 MDT
This incident affected: Canvas (Canvas, — Catalog, — Chat, — Collaboration, — Commons, — Conferences, — Document previewing, — Imports and exports, — Media tools, — Notifications, — Support: Phones/Chat, — Support: Webform/email, — ePortfolios, — Gauge).