To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas for some users
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 15, 2020 - 16:52 MDT
Monitoring
Our DevOps team have identified and implemented a fix, and we're monitoring the results. We'll provide another update in a few minutes.
Posted Jul 15, 2020 - 16:39 MDT
Investigating
A small subset of Canvas users are seeing slow load times in Canvas. Our DevOps team are currently looking into the issue, we'll provide an update shortly.
Posted Jul 15, 2020 - 16:27 MDT
This incident affected: Canvas (Canvas LMS).