To view uptime history for your instance of Canvas, click here.

Some users are experiencing slow load times for New Quizzes.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Dec 13, 2022 - 19:12 MST

Update

We are continuing to monitor as our fix is implemented.
Posted Dec 13, 2022 - 17:05 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2022 - 11:41 MST

Investigating

We are continuing to investigate this issue.
Posted Dec 13, 2022 - 11:40 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 13, 2022 - 11:10 MST

Investigating

Some users in the US are experiencing slow load times for New Quizzes.
Posted Dec 13, 2022 - 10:05 MST
This incident affected: Instructure.