Some US based schools are running into longer than normal load times
Incident Report for Instructure
Resolved
The issue has been resolved, and users should be able to access Canvas as expected. Thank you so much for your patience.
Posted Sep 05, 2019 - 07:19 MDT
Investigating
We are receiving reports that Canvas is experiencing longer than normal load times for some schools based in the US. Our DevOps team investigating this issue, and we'll provide an update on this shortly.
Posted Sep 05, 2019 - 07:05 MDT
This incident affected: Canvas (Canvas).