To view uptime history for your instance of Canvas, click here.

Page Errors in Canvas
Incident Report for Instructure
Resolved
Our engineering team has resolved the page errors in Canvas.
Posted Oct 24, 2022 - 14:57 MDT
Investigating
Some users are experiencing issues page errors in Canvas. We will update this status as we have additional information.
Posted Oct 24, 2022 - 14:33 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).