To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 02:19 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2020 - 01:41 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 01:31 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 01:05 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 00:51 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 00:35 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 00:20 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 00:04 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2020 - 23:49 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2020 - 23:34 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2020 - 23:20 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2020 - 23:04 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2020 - 22:49 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 15, 2020 - 22:34 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 15, 2020 - 22:02 MDT
Investigating
We are aware of an issue where some users are experiencing long load times when accessing Canvas. We are currently investigating this issue.
Posted Jun 15, 2020 - 21:58 MDT
This incident affected: Canvas (Canvas LMS).