To view uptime history for your instance of Canvas, click here.

Users are experiencing errors when attempting to use the Immersive Reader
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 11, 2020 - 20:05 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2020 - 17:23 MDT
Investigating
Users are experiencing errors when attempting to use the Immersive Reader. When users click on the button, the feature is unresponsive. Our Engineering team is working to resolve this.
Posted Sep 11, 2020 - 14:01 MDT