To view uptime history for your instance of Canvas, click here.

Amazon S3 performance
Incident Report for Instructure
Resolved
The Amazon S3 regional endpoint for the US-EAST-1 Region is operating normally. Notification and file upload functionality in Canvas should now be working as intended.
Posted Mar 20, 2018 - 10:34 MDT
Monitoring
Some users may experience error messages when attempting to submit in Canvas, and notifications are not being sent. This is due to degraded performance of Amazon's S3 servers. Our DevOps team is monitoring the situation and we will provide updates as they become available. You can follow Amazon statuses directly by visiting http://status.aws.amazon.com/.
Posted Mar 20, 2018 - 10:08 MDT