To view uptime history for your instance of Canvas, click here.

Docviewer Errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 09:06 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2022 - 08:53 MDT
Investigating
We are seeing some users are experiencing errors when attempting to access Submissions in Speedgrader.
Update - This appears to be errors due to Docviewer so this may occur in Files, submission details, etc.
Posted Apr 22, 2022 - 08:37 MDT
This incident affected: Canvas (Canvas).