To view uptime history for your instance of Canvas, click here.

Page Errors When Accessing Newly Created Content in Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 09, 2024 - 10:05 MDT
Investigating
A small amount of users may encounter page errors when accessing newly created content in Canvas.
Posted May 09, 2024 - 09:12 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).