To view uptime history for your instance of Canvas, click here.

Slow load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 19:19 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2020 - 18:38 MDT
Investigating
Some users are seeing slow load times when they are accessing Canvas. Our team is currently investigating the cause of the load times.
Posted Sep 30, 2020 - 18:32 MDT
This incident affected: Canvas (Canvas).