To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas

Incident Report for Instructure

Resolved

Canvas has resumed normal operational parameters, and we appreciate your patience while our team looked into this.
Posted Feb 21, 2020 - 14:05 MST

Monitoring

Our Devops Team was able to identify the issue, and deploy a fix. We're not longer seeing users experiencing long load times, but we'll monitor the behavior for the next few minutes.
Posted Feb 21, 2020 - 13:50 MST

Investigating

Some users are experiencing long load times when accessing Canvas. Our DevOps team is aware and currently investigating the issue, we'll provide an update shortly.
Posted Feb 21, 2020 - 13:43 MST
This incident affected: Canvas (Canvas LMS).