To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 06:24 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2021 - 06:20 MST
Investigating
We are currently investigating this issue.
Posted Jan 14, 2021 - 06:10 MST
This incident affected: Canvas (Canvas).